Welcome to the new packages.gentoo.org! Please let us know about any issues you encounter and share your feedback here.


Oracle's Java SE Development Kit


Available Versions

Version amd64 x86 alpha arm hppa ia64 ppc ppc64 sparc : 1.6 F, S [M]amd64 [M]x86 [M]alpha [M]arm [M]hppa [M]ia64 [M]ppc [M]ppc64 [M]sparc

Package Metadata


  • Sun JDK and JRE contain critical vulnerabilities and receive no further updates; masking to make users aware of this, users that still need this package and have no alternative can unmask at their own risk. See bug #473830. # This is continued by Oracle Corporation, which has acquired Sun Microsystems in early 2010; as per https://en.wikipedia.gentoo.org/wiki/Sun_acquisition_by_Oracle # Users are suggested to upgrade to one of the newer Oracle packages like dev-java/oracle-jdk-bin or dev-java/oracle-jre-bin or choose another alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea. # Most of these packages provide a jce USE flag for those whom need the Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that works depends from VM to VM, it seems to work for most except for the IBM VMs.
    Affected packages: dev-java/sun-jdk, dev-java/sun-jre-bin, dev-java/sun-jce-bin