Pkgcheck Warnings

  • All Versions
    • MissingRemoteId
      missing remote-id of type 'github' with value 'typemytype/booleanOperations' (inferred from URI 'https://github.com/typemytype/booleanOperations')
    • UnstableOnly
      for arches: [ arm, ppc64 ], all versions are unstable: [ 0.9.0-r1 ]
  • 0.9.0-r1
    • DistutilsNonPEP517Build
      uses deprecated non-PEP517 build mode, please switch to DISTUTILS_USE_PEP517=...
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm64, x86 ], potentials: [ ~arm, ~ppc64 ]
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_11
    • PythonGHDistfileSuffix
      GitHub archive 'booleanOperations-0.9.0.tar.gz' ('https://github.com/typemytype/booleanOperations/archive/0.9.0.tar.gz') is not using '.gh.tar.gz' suffix

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.