dev-ros/
ament_pep257

Checks code against style conventions in PEP 8 and generate test result files

https://github.com/ament/ament_lint

Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 0.10.0, 0.10.1, 0.10.4, 0.11.2 ]
  • 9999
  • 0.11.2
  • 0.10.4
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_9, python3_10
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 0.11.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (17 total) failed REQUIRED_USE: python_targets_python3_8
  • 0.10.1
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_9, python3_10
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 0.10.4, 0.11.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (17 total) failed REQUIRED_USE: python_targets_python3_8
  • 0.10.0
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_9, python3_10
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 0.10.1, 0.10.4, 0.11.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (17 total) failed REQUIRED_USE: python_targets_python3_8

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.