Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 1.2.2 ]
  • 9999
    • PythonAnyMismatchedDepHasVersionCheck
      BDEPEND: missing check for ros-meta/ament_cmake[${PYTHON_USEDEP}] in python_gen_any_dep
    • PythonAnyMismatchedDepHasVersionCheck
      DEPEND: missing check for ros-meta/ament_cmake[${PYTHON_USEDEP}] in python_check_deps
    • PythonHasVersionUsage
      usage of has_version on line: 37, replace with python_has_version
  • 1.2.2
    • PythonAnyMismatchedDepHasVersionCheck
      BDEPEND: missing check for ros-meta/ament_cmake[${PYTHON_USEDEP}] in python_gen_any_dep
    • PythonAnyMismatchedDepHasVersionCheck
      DEPEND: missing check for ros-meta/ament_cmake[${PYTHON_USEDEP}] in python_check_deps
    • PythonHasVersionUsage
      usage of has_version on line: 37, replace with python_has_version

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.