dev-util/
nvidia-cuda-toolkit

NVIDIA CUDA Toolkit (compiler and friends)

https://developer.nvidia.com/cuda-zone

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arch: [ amd64 ], all versions are unstable: [ 6.5.14, 6.5.19-r1, 7.5.18-r2, 8.0.44, 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1 ]
UnstableOnly for arch: [ x86 ], all versions are unstable: [ 6.5.14, 6.5.19-r1 ]
UnstableOnly for arch: [ amd64 ], all versions are unstable: [ 6.5.14, 6.5.19-r1, 7.5.18-r2, 8.0.44, 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1 ]
UnstableOnly for arch: [ x86 ], all versions are unstable: [ 6.5.14, 6.5.19-r1 ]
10.2.89-r2 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
10.1.243-r3 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
10.1.168-r2 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
10.1.105-r3 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
10.0.130 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
9.2.88 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
9.1.85 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
9.0.176 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
8.0.61 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
8.0.44 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
RedundantVersion slot(0) keywords are overshadowed by versions: 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
RedundantVersion slot(0) keywords are overshadowed by versions: 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
7.5.18-r2 : 0 B, M ~amd64 -x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 8.0.44, 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 8.0.44, 8.0.61, 9.0.176, 9.1.85, 9.2.88, 10.0.130, 10.1.105-r2, 10.1.168-r1, 10.1.243-r2, 10.2.89-r1
6.5.19-r1 : 0 B, M ~amd64 ~x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
DeprecatedEapi uses deprecated EAPI 5
MissingUseDepDefault RDEPEND="<x11-drivers/nvidia-drivers-346.35[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
NonexistentDeps RDEPEND: nonexistent package: <sys-devel/gcc-4.9
DeprecatedEapi uses deprecated EAPI 5
MissingUseDepDefault RDEPEND="<x11-drivers/nvidia-drivers-346.35[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
NonexistentDeps RDEPEND: nonexistent package: <sys-devel/gcc-4.9
6.5.14 : 0 B, M ~amd64 ~x86 -alpha -arm -arm64 -hppa -ia64 -ppc -ppc64 -sparc
DeprecatedEapi uses deprecated EAPI 5
MissingUseDepDefault RDEPEND="<x11-drivers/nvidia-drivers-346.35[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
MissingUseDepDefault RDEPEND=">=x11-drivers/nvidia-drivers-340.32[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
NonexistentDeps RDEPEND: nonexistent package: <sys-devel/gcc-4.9
RedundantVersion slot(0) keywords are overshadowed by version: 6.5.19-r1
DeprecatedEapi uses deprecated EAPI 5
MissingUseDepDefault RDEPEND="<x11-drivers/nvidia-drivers-346.35[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
MissingUseDepDefault RDEPEND=">=x11-drivers/nvidia-drivers-340.32[uvm]": USE flag 'uvm' missing from package: [ x11-drivers/nvidia-drivers-340.108 ]
NonexistentDeps RDEPEND: nonexistent package: <sys-devel/gcc-4.9
RedundantVersion slot(0) keywords are overshadowed by version: 6.5.19-r1

Masks

  • Old versions of CUDA and their reverse dependencies. They do not support GCC 5+, and are really old. (updated 2017-12-27 with cuda < 8 because of gcc < 5 mask)
    <dev-util/nvidia-cuda-toolkit-8
    Michał Górny <mgorny@gentoo.org> (2017-05-20 00:00:00 +0000 UTC)

Package Metadata

Changelog