Pkgcheck Warnings

  • All Versions
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.1/desktop/gnome' (76 total) failed REQUIRED_USE: exactly-one-of ( gbm wayland X )
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm64, x86 ], potential: [ ~arm ]
    • DeprecatedDep
      DEPEND: deprecated dependency: media-sound/pulseaudio
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 17, 125
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • StableRequest
      slot(0) no change in 79 days for unstable keywords: [ ~amd64, ~arm64, ~x86 ]
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • UnstableOnly
      for arch: [ arm ], all versions are unstable: [ 19.5-r1, 20.3 ]
    • DeprecatedDep
      RDEPEND: deprecated dependency: media-sound/pulseaudio
  • 9999
    • 20.9999
      • PythonCompatUpdate
        PYTHON_COMPAT update available: python3_12
    • 20.3
      • RequiredUseDefaults
        profile: 'default/linux/amd64/17.1/desktop/gnome' (76 total) failed REQUIRED_USE: exactly-one-of ( gbm wayland X )
      • StableRequest
        slot(0) no change in 79 days for unstable keywords: [ ~amd64, ~arm64, ~x86 ]
      • PythonCompatUpdate
        PYTHON_COMPAT update available: python3_12
    • 19.5-r1
      • PotentialStable
        slot(0), stabled arches: [ amd64, arm64, x86 ], potential: [ ~arm ]
      • DeprecatedDep
        DEPEND: deprecated dependency: media-sound/pulseaudio
      • ExcessiveLineLength
        excessive line length (over 120 characters) on lines: 17, 125
      • PythonCompatUpdate
        PYTHON_COMPAT update available: python3_12
      • DeprecatedDep
        RDEPEND: deprecated dependency: media-sound/pulseaudio

    Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.