Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arches: [ amd64, x86 ], all versions are unstable: [ 1.8.0, 1.8.1, 1.9.0-r1, 1.9.3 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 66
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 66
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.9.0-r1, 1.9.3
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.9.3
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.8.1, 1.9.0-r1, 1.9.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 61, 64
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 61, 64
  • 1.9.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 66
  • 1.9.0-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 66
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.9.3
  • 1.8.1
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.9.0-r1, 1.9.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 61, 64
  • 1.8.0
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.8.1, 1.9.0-r1, 1.9.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 61, 64

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.