Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 6.1.7, 6.1.8-r1, 6.1.9 ]
  • 6.1.9
    • PythonGHDistfileSuffix
      GitHub archive 'err-6.1.9.tar.gz' ('https://github.com/errbotio/errbot/archive/6.1.9.tar.gz') is not using '.gh.tar.gz' suffix
  • 6.1.8-r1
    • PythonGHDistfileSuffix
      GitHub archive 'err-6.1.8.tar.gz' ('https://github.com/errbotio/errbot/archive/6.1.8.tar.gz') is not using '.gh.tar.gz' suffix
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 6.1.9
  • 6.1.7
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_10
    • PythonGHDistfileSuffix
      GitHub archive 'err-6.1.7.tar.gz' ('https://github.com/errbotio/errbot/archive/6.1.7.tar.gz') is not using '.gh.tar.gz' suffix
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 6.1.8-r1, 6.1.9
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ( python_targets_python3_8 || python_targets_python3_9 )

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.