Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ sparc ], all versions are unstable: [ 2.44.1, 2.44.1-r410, 2.44.1-r600, 2.44.2, 2.44.2-r410, 2.44.2-r600 ]
  • 2.44.2-r600
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 34, 35, 36
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (134 total) failed REQUIRED_USE: ( aqua || wayland || X )
  • 2.44.2-r410
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (134 total) failed REQUIRED_USE: ( aqua || wayland || X )
  • 2.44.2
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (134 total) failed REQUIRED_USE: ( aqua || wayland || X )
  • 2.44.1-r600
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 34, 35, 36
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PotentialStable
      slot(6), stabled arches: [ amd64, arm, arm64, ppc, ppc64, x86 ], potential: [ ~sparc ]
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (247 total) failed REQUIRED_USE: ( aqua || wayland || X )
  • 2.44.1-r410
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PotentialStable
      slot(4.1), stabled arches: [ amd64, arm, arm64, ppc, ppc64, x86 ], potential: [ ~sparc ]
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (247 total) failed REQUIRED_USE: ( aqua || wayland || X )
  • 2.44.1
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Carp'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-Data-Dumper'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • PotentialStable
      slot(4), stabled arches: [ amd64, arm, arm64, ppc, ppc64, x86 ], potential: [ ~sparc ]
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_13
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (247 total) failed REQUIRED_USE: ( aqua || wayland || X )

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.