Pkgcheck Warnings

  • All Versions
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • UnstableOnly
      for arches: [ hppa, ppc ], all versions are unstable: [ 2.4.59-r2, 2.5.14, 2.5.16, 2.6.3-r7, 2.6.4-r1, 2.6.4-r2, 2.6.5, 2.6.6, 2.6.6-r1 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 343, 712
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.6, 2.6.6-r1
    • StableRequest
      slot(0) no change in 216 days for unstable keywords: [ ~amd64, ~arm, ~arm64, ~ppc64, ~sparc, ~x86 ]
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • UnusedInherits
      unused eclass: multibuild
    • TotalSizeViolation
      files/ directory exceeds 50.0 KiB in size; 56.5 KiB total
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.3-r7, 2.6.4-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 342, 711
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • BetterCompressionUri
      line 20: better compression URI using extension '.tar.bz2' for 'https://gitlab.com/openldap/${PN}/-/archive/OPENLDAP_REL_ENG_${MY_PV}/${PN}-OPENLDAP_REL_ENG_${MY_PV}.tar.gz'
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.5, 2.6.6, 2.6.6-r1
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • UnusedInherits
      unused eclass: multibuild
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.3-r7, 2.6.4-r1, 2.6.4-r2, 2.6.5, 2.6.6, 2.6.6-r1
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm, arm64, ppc64, sparc, x86 ], potentials: [ ~hppa, ~ppc ]
    • UnusedInherits
      unused eclass: multibuild
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 340, 709
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 678
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 696, 760
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.6.6-r1
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.6.4-r1
    • UnusedInherits
      unused eclass: multibuild
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.5.14, 2.6.3-r7, 2.6.4-r1
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
  • 2.6.6-r1
    • UnusedInherits
      unused eclass: multibuild
  • 2.6.6
    • StableRequest
      slot(0) no change in 216 days for unstable keywords: [ ~amd64, ~arm, ~arm64, ~ppc64, ~sparc, ~x86 ]
    • UnusedInherits
      unused eclass: multibuild
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.6.6-r1
  • 2.6.5
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.6, 2.6.6-r1
    • UnusedInherits
      unused eclass: multibuild
  • 2.6.4-r2
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.5, 2.6.6, 2.6.6-r1
    • UnusedInherits
      unused eclass: multibuild
  • 2.6.4-r1
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 343, 712
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm, arm64, ppc64, sparc, x86 ], potentials: [ ~hppa, ~ppc ]
  • 2.6.3-r7
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • BetterCompressionUri
      line 20: better compression URI using extension '.tar.bz2' for 'https://gitlab.com/openldap/${PN}/-/archive/OPENLDAP_REL_ENG_${MY_PV}/${PN}-OPENLDAP_REL_ENG_${MY_PV}.tar.gz'
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 678
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.6.4-r1
  • 2.5.16
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.3-r7, 2.6.4-r1, 2.6.4-r2, 2.6.5, 2.6.6, 2.6.6-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 340, 709
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
  • 2.5.14
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.6.3-r7, 2.6.4-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 342, 711
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
  • 2.4.59-r2
    • UseFlagWithoutDeps
      special small-files USE flag without effect on dependencies: [ ipv6 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 696, 760
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.5.14, 2.6.3-r7, 2.6.4-r1

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.