Pkgcheck Warnings

  • All Versions
  • 1.31
    • DeprecatedEapi
      uses deprecated EAPI 6
    • DeprecatedEclass
      uses deprecated eclass: epatch (migrate to eapply from EAPI 7)
    • StableRequest
      slot(0) no change in 169 days for unstable keywords: [ ~amd64, ~ppc, ~ppc64, ~sparc, ~x86 ]
  • 1.28-r1
    • DeprecatedEapi
      uses deprecated EAPI 6
    • DeprecatedEclass
      uses deprecated eclass: epatch (migrate to eapply from EAPI 7)
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.31
  • 1.27-r1
    • DeprecatedEapi
      uses deprecated EAPI 6
    • DeprecatedEclass
      uses deprecated eclass: epatch (migrate to eapply from EAPI 7)

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.