Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ arm ], all versions are unstable: [ 2.4.2-r2, 2.5.0-r1, 2.5.1, 2.5.2, 2.5.3 ]
  • 2.5.3
    • LaggingStable
      slot(0), stabled arch: [ amd64 ], lagging: [ ~x86 ]
    • PotentialStable
      slot(0), stabled arch: [ amd64 ], potential: [ ~arm ]
  • 2.5.2
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (186 total) failed REQUIRED_USE: ( python_targets_python3_10 || python_targets_python3_11 )
  • 2.5.1
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.5.2, 2.5.3
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (126 total) failed REQUIRED_USE: ( python_targets_python3_10 || python_targets_python3_11 )
  • 2.5.0-r1
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2.5.1, 2.5.2, 2.5.3
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (126 total) failed REQUIRED_USE: ( python_targets_python3_10 || python_targets_python3_11 )
  • 2.4.2-r2
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.5.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/23.0' (186 total) failed REQUIRED_USE: ( python_targets_python3_10 || python_targets_python3_11 )

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.