Pkgcheck Warnings

  • All Versions
  • 9999
    • DeprecatedEapi
      uses deprecated EAPI 6
    • IndirectInherits
      depend.apache: indirect inherit usage: 'need_apache2_4', line 23
    • InternalEclassUsage
      depend.apache: internal usage: '_init_apache2', line 31
    • InternalEclassUsage
      depend.apache: internal usage: '_init_apache2_late', line 32
  • 3.3.3
    • DeprecatedEapi
      uses deprecated EAPI 6
    • IndirectInherits
      depend.apache: indirect inherit usage: 'need_apache2_4', line 23
    • InternalEclassUsage
      depend.apache: internal usage: '_init_apache2', line 31
    • InternalEclassUsage
      depend.apache: internal usage: '_init_apache2_late', line 32
    • StableRequest
      slot(2) no change in 860 days for unstable keywords: [ ~amd64, ~x86 ]
  • 3.3.2
    • DeprecatedEapi
      uses deprecated EAPI 5
    • IndirectInherits
      depend.apache: indirect inherit usage: 'need_apache2_4', line 15

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.