Pkgcheck Warnings

  • All Versions
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 256, 257, 258, 270, 271, 298
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.0.23
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 252, 253, 254, 264, 290
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (221 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || ruby )
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 254, 255, 256, 266, 292
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (442 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || python-asyncio || ruby )
    • StableRequest
      slot(0) no change in 136 days for unstable keywords: [ ~amd64, ~arm, ~arm64, ~x86 ]
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (221 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || ruby )
  • 2.0.23
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 252, 253, 254, 264, 290
    • StableRequest
      slot(0) no change in 136 days for unstable keywords: [ ~amd64, ~arm, ~arm64, ~x86 ]
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (221 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || ruby )
  • 2.0.21-r2
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2.0.23
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (221 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || ruby )
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 254, 255, 256, 266, 292
  • 2.0.21-r1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 256, 257, 258, 270, 271, 298
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (442 total) failed REQUIRED_USE: ( cgi || mono || perl || go || lua || php || python || python-asyncio || ruby )

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.