Use libsdl2 instead of libsdl

Packages describing “sdl2” as local USE flag

Package “sdl2” Flag Description
games-engines/exult Use libsdl2 instead of libsdl
dev-games/openscenegraph Use media-libs/libsdl2 additionally to media-libs/libsdl
dev-games/openscenegraph-openmw Use media-libs/libsdl2 additionally to media-libs/libsdl
games-rpg/manaplus Use libsdl2 instead of libsdl
games-action/dxx-rebirth Use libSDL2, SDL2-mixer instead of libSDL-1* and SDL-mixer-1*
media-libs/gegl Add support for Simple Direct Layer 2.0 (media-libs/libsdl2)

All packages providing a “sdl2” USE flag (4)