app-admin/
ansible-lint

Checks ansible playbooks for practices and behaviour that can be improved

https://github.com/ansible-community/ansible-lint

Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 4.0.1, 4.1.0, 5.0.2 ]
  • 5.0.2
  • 4.1.0
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_8, python3_9
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 5.0.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: python_targets_python3_7
  • 4.0.1
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_8, python3_9
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 4.1.0, 5.0.2
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: python_targets_python3_7

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.