app-admin/
fluentd

data collector and unified logging layer (project under CNCF)

https://www.fluentd.org

Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 1.2.6-r1, 1.3.1, 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.4.2, 1.9.0 ]
  • 1.9.0
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
  • 1.4.2
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby26(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.9.0
  • 1.4.1
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25
  • 1.4.0
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.4.1, 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25
  • 1.3.3
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.4.0, 1.4.1, 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25
  • 1.3.2
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.3.3, 1.4.0, 1.4.1, 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25
  • 1.3.1
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25
  • 1.2.6-r1
    • DeprecatedEclass
      uses deprecated eclass: user (migrate to acct-user/acct-group packages)
    • MissingSlotDep
      '>=dev-ruby/tzinfo-1.0[ruby_targets_ruby25(-)]' matches more than one slot: [ 1, 2 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.3.1, 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.4.2, 1.9.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (16 total) failed REQUIRED_USE: ruby_targets_ruby25

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.