Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ x86 ], all versions are unstable: [ 3.4.0, 4.0.0, 4.2.1, 4.2.2, 4.2.3 ]
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • PotentialStable
      slot(0), stabled arch: [ amd64 ], potential: [ ~x86 ]
    • UnstableSrcUri
      unstable SRC_URI: [ https://github.com/puppetlabs/puppet-lint/pull/181.patch ]
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 4.0.0, 4.2.1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.2.3
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.2.1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • StableRequest
      slot(0) no change in 98 days for unstable keyword: [ ~amd64 ]
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
  • 4.2.3
    • UnstableSrcUri
      unstable SRC_URI: [ https://github.com/puppetlabs/puppet-lint/pull/181.patch ]
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • StableRequest
      slot(0) no change in 98 days for unstable keyword: [ ~amd64 ]
  • 4.2.2
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.2.3
  • 4.2.1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
    • PotentialStable
      slot(0), stabled arch: [ amd64 ], potential: [ ~x86 ]
  • 4.0.0
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.2.1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33
  • 3.4.0
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 4.0.0, 4.2.1
    • RubyCompatUpdate
      USE_RUBY update available: ruby33

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.