Pkgcheck Warnings

  • All Versions
    • MissingUseDepDefault
      RDEPEND=">=www-servers/apache-2.4[apache2_modules_alias,apache2_modules_authn_core,apache2_modules_authz_core,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_fcgid]": USE flag 'apache2_modules_fcgid' missing from packages: [ www-servers/apache-2.4.58, www-servers/apache-2.4.58-r2, www-servers/apache-2.4.59, www-servers/apache-2.4.59-r1 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.4.0-r1
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-IO-Compress'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-IO-Compress'
    • VariableScope
      variable 'EROOT' used in 'global scope' on lines: 58, 59, 60, 61, 62
  • 4.4.0-r1
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-IO-Compress'
    • VariableScope
      variable 'EROOT' used in 'global scope' on lines: 58, 59, 60, 61, 62
  • 3.3.1-r6
    • MissingUseDepDefault
      RDEPEND=">=www-servers/apache-2.4[apache2_modules_alias,apache2_modules_authn_core,apache2_modules_authz_core,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_fcgid]": USE flag 'apache2_modules_fcgid' missing from packages: [ www-servers/apache-2.4.58, www-servers/apache-2.4.58-r2, www-servers/apache-2.4.59, www-servers/apache-2.4.59-r1 ]
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.4.0-r1
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-IO-Compress'

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.