Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arches: [ arm, ppc ], all versions are unstable: [ 7.2.4, 7.2.6, 7.2.7, 8.0.4, 8.0.5, 8.1.2, 8.1.3 ]
  • 9999
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 811, 890
  • 8.1.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 789, 868
  • 8.1.2
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 8.1.3
    • StableRequest
      slot(0) no change in 43 days for unstable keywords: [ ~amd64, ~arm64, ~ppc64, ~x86 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 789, 868
  • 8.0.5
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 790, 869
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 8.1.2, 8.1.3
  • 8.0.4
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 790, 869
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm64, ppc64, x86 ], potentials: [ ~arm, ~ppc ]
  • 7.2.7
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 8.0.4, 8.0.5, 8.1.2, 8.1.3
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 791, 870
  • 7.2.6
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 7.2.7, 8.0.4, 8.0.5, 8.1.2, 8.1.3
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 792, 871
  • 7.2.4
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 792, 871
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 8.0.4

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.