Pkgcheck Warnings

  • All Versions
  • 2021
    • BadDefaultUseFlags
      bad default USE flags: '-ada_target_gnat_2017', '-ada_target_gnat_2018', '-ada_target_gnat_2019'
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (27 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2020 ada_target_gnat_2021 )
  • 2020-r1
    • BadDefaultUseFlags
      bad default USE flags: '-ada_target_gnat_2017', '-ada_target_gnat_2018'
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2021
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (27 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2019 ada_target_gnat_2020 ada_target_gnat_2021 )
  • 2020
    • BadDefaultUseFlags
      bad default USE flags: '-ada_target_gnat_2017', '-ada_target_gnat_2018', '-ada_target_gnat_2020', '-ada_target_gnat_2021'
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (54 total) failed REQUIRED_USE: ada_target_gnat_2019
  • 2019-r1
    • BadDefaultUseFlags
      bad default USE flags: '-ada_target_gnat_2017', '-ada_target_gnat_2018', '-ada_target_gnat_2020', '-ada_target_gnat_2021'
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 2020
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (54 total) failed REQUIRED_USE: ada_target_gnat_2019
  • 2018-r2
    • BadDefaultUseFlags
      bad default USE flags: '-ada_target_gnat_2020', '-ada_target_gnat_2021'
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 2019-r1, 2020

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.