Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ arm ], all versions are unstable: [ 13.3_p1-r1, 13.19_p1, 15.0_p1 ]
  • 15.0_p1
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
    • PotentialStable
      slot(0), stabled arch: [ arm64 ], potential: [ ~arm ]
  • 13.19_p1
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 15.0_p1
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_12
  • 13.3_p1-r1
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_11, python3_12
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 15.0_p1
    • RequiredUseDefaults
      profile: 'default/linux/arm/17.0' (71 total) failed REQUIRED_USE: python_targets_python3_10

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.