Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arches: [ arm, sparc ], all versions are unstable: [ 3.23.0, 3.25.0, 3.29.0 ]
  • 3.29.0
    • 3.25.0
      • DistutilsNonPEP517Build
        uses deprecated non-PEP517 build mode, please switch to DISTUTILS_USE_PEP517=...
      • PythonCompatUpdate
        PYTHON_COMPAT updates available: python3_12, python3_13
      • RedundantVersion
        slot(0) keywords are overshadowed by version: 3.29.0
      • StableRequest
        slot(0) no change in 407 days for unstable keywords: [ ~amd64, ~arm64, ~ppc, ~ppc64, ~x86 ]
    • 3.23.0
      • DistutilsNonPEP517Build
        uses deprecated non-PEP517 build mode, please switch to DISTUTILS_USE_PEP517=...
      • PotentialStable
        slot(0), stabled arches: [ amd64, arm64, ppc, ppc64, x86 ], potentials: [ ~arm, ~sparc ]
      • PythonCompatUpdate
        PYTHON_COMPAT updates available: python3_12, python3_13

    Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.