Pkgcheck Warnings

  • All Versions
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 20
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm64, x86 ], potentials: [ ~arm, ~ppc, ~ppc64 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 20
    • MatchingChksums
      distfile 'luv-lua-compat-0.10.tar.gz' matches checksums for 'lua-compat53-0.10.tar.gz' from dev-lua/lua-bit32
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (341 total) failed REQUIRED_USE: exactly-one-of ( lua_single_target_luajit lua_single_target_lua5-1 lua_single_target_lua5-3 lua_single_target_lua5-4 )
    • UnstableOnly
      for arch: [ ppc ], all versions are unstable: [ 1.45.0.0 ]
    • UnstableOnly
      for arches: [ arm, ppc64 ], all versions are unstable: [ 1.44.2.0, 1.45.0.0 ]
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (357 total) failed REQUIRED_USE: exactly-one-of ( lua_single_target_luajit lua_single_target_lua5-1 lua_single_target_lua5-3 lua_single_target_lua5-4 )
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.45.0.0
  • 1.45.0.0
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm64, x86 ], potentials: [ ~arm, ~ppc, ~ppc64 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 20
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (357 total) failed REQUIRED_USE: exactly-one-of ( lua_single_target_luajit lua_single_target_lua5-1 lua_single_target_lua5-3 lua_single_target_lua5-4 )
  • 1.44.2.0
    • ExcessiveLineLength
      excessive line length (over 120 characters) on line: 20
    • MatchingChksums
      distfile 'luv-lua-compat-0.10.tar.gz' matches checksums for 'lua-compat53-0.10.tar.gz' from dev-lua/lua-bit32
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/musl' (341 total) failed REQUIRED_USE: exactly-one-of ( lua_single_target_luajit lua_single_target_lua5-1 lua_single_target_lua5-3 lua_single_target_lua5-4 )
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.45.0.0

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.