media-video/
ffmpeg

Complete solution to record/convert/stream audio and video. Includes libavcodec

https://ffmpeg.org/

Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ hppa ], all versions are unstable: [ 4.2.7, 4.2.8, 4.4.2, 4.4.3, 5.1.2 ]
  • 9999
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 141, 176
  • 5.1.2
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 141, 176
  • 4.4.3
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 140, 175
    • PotentialStable
      slot(0), stabled arches: [ amd64, arm, arm64, ppc, ppc64, sparc, x86 ], potential: [ ~hppa ]
  • 4.4.2
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 140, 175
    • OutdatedBlocker
      outdated blocker DEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.4.3
  • 4.2.8
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 138, 173
    • OutdatedBlocker
      outdated blocker DEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 4.4.2, 4.4.3
    • VulnerablePackage
      vulnerable via glsa(202105-24) ( ( ('fullver',) ver < 4.4 ) && not ( ('fullver',) ver >= 4.4 ) ), keywords: alpha, amd64, amd64-linux, arm, arm64, hppa, ia64, mips, ppc, ppc64, sparc, x86, x86-linux
  • 4.2.7
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 138, 173
    • OutdatedBlocker
      outdated blocker DEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!media-libs/libpostproc": last match removed 2.6 years ago
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 4.4.2, 4.4.3
    • VulnerablePackage
      vulnerable via glsa(202105-24) ( ( ('fullver',) ver < 4.4 ) && not ( ('fullver',) ver >= 4.4 ) ), keywords: alpha, amd64, amd64-linux, arm, arm64, hppa, ia64, mips, ppc, ppc64, sparc, x86, x86-linux

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.