net-misc/
websocat

Command-line client for WebSockets, like netcat, with socat-like functions

https://github.com/vi/websocat

Pkgcheck Warnings

  • All Versions
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.11.0
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • UnstableOnly
      for arch: [ amd64 ], all versions are unstable: [ 1.6.0-r2, 1.9.0, 1.10.0, 1.11.0 ]
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 222: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 176: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
    • SuboptimalCratesURICall
      line: 172: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.10.0, 1.11.0
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.9.0, 1.10.0, 1.11.0
    • SuboptimalCratesURICall
      line: 218: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
  • 1.11.0
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 222: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
  • 1.10.0
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 1.11.0
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 218: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
  • 1.9.0
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 176: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.10.0, 1.11.0
  • 1.6.0-r2
    • SuboptimalCratesSeparator
      line: 7: using - as name-version separator in CRATES is suboptimal, use name@version instead
    • SuboptimalCratesURICall
      line: 172: calling '$(cargo_crate_uris ${CRATES})' is suboptimal, use '${CARGO_CRATE_URIS}' for global CRATES instead
    • RedundantVersion
      slot(0) keywords are overshadowed by versions: 1.9.0, 1.10.0, 1.11.0

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.