Pkgcheck Warnings

  • All Versions
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.1.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (80 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (80 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
    • UnstableOnly
      for arch: [ x86 ], all versions are unstable: [ 4.0.0_pre20231218-r1, 4.0.0-r1, 4.1.0 ]
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (128 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
    • StableRequest
      slot(0) no change in 33 days for unstable keyword: [ ~amd64 ]
    • PotentialStable
      slot(0), stabled arch: [ amd64 ], potential: [ ~x86 ]
  • 4.1.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (80 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
  • 4.0.0-r1
    • RedundantVersion
      slot(0) keywords are overshadowed by version: 4.1.0
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (80 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
    • StableRequest
      slot(0) no change in 33 days for unstable keyword: [ ~amd64 ]
  • 4.0.0_pre20231218-r1
    • RequiredUseDefaults
      profile: 'default/linux/amd64/17.0/x32' (128 total) failed REQUIRED_USE: exactly-one-of ( ada_target_gnat_2021 ada_target_gcc_13 )
    • PotentialStable
      slot(0), stabled arch: [ amd64 ], potential: [ ~x86 ]

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.