openssl

Local USE flag

Packages describing “openssl” as local USE flag

Package “openssl” Flag Description
app-admin/salt Add support for using TLS via OpenSSL.
app-admin/sudo Use SHA2 from dev-libs/openssl instead of sudo's internal SHA2.
app-crypt/rhash Add support for hashes from dev-libs/openssl
app-text/mupdf Use dev-libs/openssl crypto backend
dev-db/mariadb Enable SSL connections and crypto functions using dev-libs/openssl
dev-db/mariadb-galera Enable SSL connections and crypto functions using dev-libs/openssl
dev-db/mysql Enable SSL connections and crypto functions using dev-libs/openssl
dev-db/mysql-cluster Enable SSL connections and crypto functions using dev-libs/openssl
dev-db/percona-server Enable SSL connections and crypto functions using dev-libs/openssl
dev-haskell/snap-server enable https support using dev-haskell/hsopenssl
dev-libs/apr-util Install apr_crypto_openssl module
dev-libs/xmlsec Install xmlsec-openssl library
dev-lua/luarocks Uses dev-libs/openssl for verifying lua packages instead of md5sum.
dev-vcs/cvsync Use dev-libs/openssl for hash functions.
media-libs/mesa Use dev-libs/openssl for low level sha1 utility functions. May cause issues with games from Steam.
media-video/ffmpeg Enables dev-libs/openssl support. Adds support for encrypted network protocols (TLS/HTTPS).
media-video/libav Prefer dev-libs/openssl over net-libs/gnutls to provide SSL/TLS support (notice: the resulting binaries are unredistributable).
net-fs/s3fs Enable dev-libs/openssl crypto backend
net-im/ekg2 Support encryption in sim plugin, using OpenSSL.
net-libs/gnutls Build openssl compatibility libraries
net-libs/libisds Use dev-libs/openssl as crypto backend instead of app-crypt/gpgme and dev-libs/libgcrypt
net-libs/libsrtp Use OpenSSL crypto primitives
net-libs/loudmouth Enable dev-libs/openssl support instead of gnutls (which is the default).
net-misc/iputils Use dev-libs/openssl for md5 support
net-misc/kea Use dev-libs/openssl instead of Botan
net-misc/strongswan Enable dev-libs/openssl plugin which is required for Elliptic Curve Cryptography (DH groups 19-21,25,26) and ECDSA. Also provides 3DES, AES, Blowfish, Camellia, CAST, DES, IDEA and RC5 ciphers along with MD2, MD4, MD5 and SHA1/2 hash algorithms, RSA and DH groups 1,2,5,14-18 and 22-24(4.4+) dev-libs/openssl has to be compiled with USE="-bindist".
net-proxy/shadowsocks-libev Use dev-libs/openssl as crypto backend
net-vpn/strongswan Enable dev-libs/openssl plugin which is required for Elliptic Curve Cryptography (DH groups 19-21,25,26) and ECDSA. Also provides 3DES, AES, Blowfish, Camellia, CAST, DES, IDEA and RC5 ciphers along with MD2, MD4, MD5 and SHA1/2 hash algorithms, RSA and DH groups 1,2,5,14-18 and 22-24(4.4+) dev-libs/openssl has to be compiled with USE="-bindist".
sci-mathematics/octave Use dev-libs/openssl for low level hash functions
sys-auth/pam_mysql Use OpenSSL for md5 and sha1 support
sys-fs/cryptsetup Use dev-libs/openssl crypto backend
sys-fs/ecryptfs-utils Enable dev-libs/openssl key module
sys-fs/s3fs Enable dev-libs/openssl crypto backend
x11-plugins/pidgin-sipe Enable crypto support via dev-libs/openssl