Pkgcheck Warnings

  • All Versions
    • UnstableOnly
      for arch: [ hppa ], all versions are unstable: [ 10.6.14, 10.6.15, 10.11.5 ]
  • 10.11.7
    • DroppedKeywords
      alpha, amd64-linux, hppa, loong, mips, ppc-macos, s390, x64-macos, x64-solaris, x86-linux
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 525, 1124
    • StableRequest
      slot(10.11) no change in 70 days for unstable keywords: [ ~amd64, ~arm, ~arm64, ~ppc, ~ppc64, ~x86 ]
    • StaticSrcUri
      '10.11' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.11.6
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 526, 1125
    • RedundantVersion
      slot(10.11) keywords are overshadowed by version: 10.11.7
    • StaticSrcUri
      'mariadb-10.11.6' in SRC_URI, replace with ${P}
  • 10.11.5-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 526, 1125
    • RedundantVersion
      slot(10.11) keywords are overshadowed by versions: 10.11.6, 10.11.7
    • StaticSrcUri
      '10.11' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.11.5
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 526, 1125
    • StaticSrcUri
      '10.11' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.6.17
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 536, 1135
    • LaggingStable
      slot(10.6), stabled arches: [ amd64, x86 ], lagging: [ ~arm, ~arm64, ~ppc, ~ppc64 ]
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mariadb-galera": last match removed 5.0 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mysql-cluster": last match removed 2.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/libmysqlclient-18-r1": last match removed 4.72 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/mysql-5.6-r11": last match removed 3.66 years ago
    • StaticSrcUri
      '10.6' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.6.16
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 537, 1136
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mariadb-galera": last match removed 5.0 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mysql-cluster": last match removed 2.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/libmysqlclient-18-r1": last match removed 4.72 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/mysql-5.6-r11": last match removed 3.66 years ago
    • RedundantVersion
      slot(10.6) keywords are overshadowed by version: 10.6.17
    • StaticSrcUri
      'mariadb-10.6.16' in SRC_URI, replace with ${P}
  • 10.6.15-r1
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 537, 1136
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mariadb-galera": last match removed 5.0 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mysql-cluster": last match removed 2.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/libmysqlclient-18-r1": last match removed 4.72 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/mysql-5.6-r11": last match removed 3.66 years ago
    • RedundantVersion
      slot(10.6) keywords are overshadowed by versions: 10.6.16, 10.6.17
    • StaticSrcUri
      '10.6' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.6.15
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 537, 1136
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mariadb-galera": last match removed 5.0 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mysql-cluster": last match removed 2.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/libmysqlclient-18-r1": last match removed 4.72 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/mysql-5.6-r11": last match removed 3.66 years ago
    • StaticSrcUri
      '10.6' in SRC_URI, replace with $(ver_cut 1-2)
  • 10.6.14
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 537, 1136
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mariadb-galera": last match removed 5.0 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!dev-db/mysql-cluster": last match removed 2.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/libmysqlclient-18-r1": last match removed 4.72 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<virtual/mysql-5.6-r11": last match removed 3.66 years ago
    • StaticSrcUri
      '10.6' in SRC_URI, replace with $(ver_cut 1-2)

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.