dev-haskell/
atomic-primops

A safe approach to CAS and other atomic ops in Haskell

https://github.com/rrnewton/haskell-lockfree/wiki

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arches: [ amd64, x86 ], all versions are unstable: [ 0.4-r1, 0.6.1.1, 0.7, 0.8.0.4, 0.8.3 ]
UnstableOnly for arches: [ amd64, x86 ], all versions are unstable: [ 0.4-r1, 0.6.1.1, 0.7, 0.8.0.4, 0.8.3 ]
0.8.3 : 0 ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
0.8.0.4 : 0 ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
RedundantVersion slot(0) keywords are overshadowed by version: 0.8.3
RedundantVersion slot(0) keywords are overshadowed by version: 0.8.3
0.7 : 0 ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 0.8.0.4, 0.8.3
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 0.8.0.4, 0.8.3
0.6.1.1 : 0 ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 0.7, 0.8.0.4, 0.8.3
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 0.7, 0.8.0.4, 0.8.3
0.4-r1 : 0 ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
OutdatedBlocker outdated blocker DEPEND="!<dev-haskell/cabal-1.17": last match removed 3.43 years ago
RedundantVersion slot(0) keywords are overshadowed by versions: 0.6.1.1, 0.7, 0.8.0.4, 0.8.3
DeprecatedEapi uses deprecated EAPI 5
OutdatedBlocker outdated blocker DEPEND="!<dev-haskell/cabal-1.17": last match removed 3.45 years ago
RedundantVersion slot(0) keywords are overshadowed by versions: 0.6.1.1, 0.7, 0.8.0.4, 0.8.3

Package Metadata

Changelog