Pkgcheck Warnings

  • All Versions
    • DuplicateFiles
      duplicate identical files in FILESDIR: 'files/2.5/002-autoconf-2.70.patch', 'files/2.6/002-autoconf-2.70.patch'
    • DuplicateFiles
      duplicate identical files in FILESDIR: 'files/2.5/005_no-undefined-ext.patch', 'files/2.6/005_no-undefined-ext.patch'
    • DuplicateFiles
      duplicate identical files in FILESDIR: 'files/2.6/010-default-gem-location.patch', 'files/2.7/010-default-gem-location.patch'
  • 3.0.1
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/test-unit-3.3.7[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/test-unit-3.3.7 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ virtual/rubygems-15 ]
  • 3.0.0-r2
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/bundler-2.1.4[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/bundler-2.1.4 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/test-unit-3.3.7[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/test-unit-3.3.7 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(3.0) keywords are overshadowed by version: 3.0.1
  • 3.0.0-r1
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/bundler-2.1.4[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/bundler-2.1.4 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/test-unit-3.3.7[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/test-unit-3.3.7 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(3.0) keywords are overshadowed by versions: 3.0.0-r2, 3.0.1
  • 3.0.0
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/bundler-2.1.4[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/bundler-2.1.4 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/test-unit-3.3.7[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ dev-ruby/test-unit-3.3.7 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby30]": USE flag 'ruby_targets_ruby30' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(3.0) keywords are overshadowed by versions: 3.0.0-r1, 3.0.0-r2, 3.0.1
  • 2.7.3-r1
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
  • 2.7.3
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(2.7) keywords are overshadowed by version: 2.7.3-r1
  • 2.7.2-r1
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(2.7) keywords are overshadowed by versions: 2.7.3, 2.7.3-r1
  • 2.7.2
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
    • MissingUseDepDefault
      PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
    • RedundantVersion
      slot(2.7) keywords are overshadowed by versions: 2.7.2-r1, 2.7.3, 2.7.3-r1
  • 2.6.7
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
  • 2.6.6-r3
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
    • RedundantVersion
      slot(2.6) keywords are overshadowed by version: 2.6.7
  • 2.6.6-r2
    • MissingUseDepDefault
      PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
  • 2.5.9
  • 2.5.8-r1
    • RedundantVersion
      slot(2.5) keywords are overshadowed by version: 2.5.9
  • 2.5.8

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.