dev-lang/
ruby

An object-oriented scripting language

https://www.ruby-lang.org/

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
DuplicateFiles duplicate identical files in FILESDIR: 'files/2.5/005_no-undefined-ext.patch', 'files/2.6/005_no-undefined-ext.patch'
DuplicateFiles duplicate identical files in FILESDIR: 'files/2.6/010-default-gem-location.patch', 'files/2.7/010-default-gem-location.patch'
UnstableOnly for arch: [ alpha ], all versions are unstable: [ 2.4.10, 2.5.8, 2.5.8-r1, 2.6.6, 2.6.6-r1, 2.6.6-r2, 2.7.1, 2.7.1-r1, 2.7.1-r2 ]
DuplicateFiles duplicate identical files in FILESDIR: 'files/2.5/005_no-undefined-ext.patch', 'files/2.6/005_no-undefined-ext.patch'
DuplicateFiles duplicate identical files in FILESDIR: 'files/2.6/010-default-gem-location.patch', 'files/2.7/010-default-gem-location.patch'
UnstableOnly for arch: [ alpha ], all versions are unstable: [ 2.4.10, 2.5.8, 2.5.8-r1, 2.6.6, 2.6.6-r1, 2.6.6-r2, 2.7.1, 2.7.1-r1, 2.7.1-r2 ]
2.7.1-r2 : 2.7 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
2.7.1-r1 : 2.7 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
RedundantVersion slot(2.7) keywords are overshadowed by version: 2.7.1-r2
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
RedundantVersion slot(2.7) keywords are overshadowed by version: 2.7.1-r2
2.7.1 : 2.7 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
RedundantVersion slot(2.7) keywords are overshadowed by versions: 2.7.1-r1, 2.7.1-r2
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.3.1[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/did_you_mean-1.3.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/rdoc-6.1.2[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ dev-ruby/rdoc-6.1.2 ]
MissingUseDepDefault PDEPEND="virtual/rubygems[ruby_targets_ruby27]": USE flag 'ruby_targets_ruby27' missing from package: [ virtual/rubygems-15 ]
RedundantVersion slot(2.7) keywords are overshadowed by versions: 2.7.1-r1, 2.7.1-r2
2.6.6-r2 : 2.6 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
2.6.6-r1 : 2.6 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
RedundantVersion slot(2.6) keywords are overshadowed by version: 2.6.6-r2
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
RedundantVersion slot(2.6) keywords are overshadowed by version: 2.6.6-r2
2.6.6 : 2.6 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
RedundantVersion slot(2.6) keywords are overshadowed by versions: 2.6.6-r1, 2.6.6-r2
MissingUseDepDefault PDEPEND=">=dev-ruby/did_you_mean-1.2.1[ruby_targets_ruby26]": USE flag 'ruby_targets_ruby26' missing from package: [ dev-ruby/did_you_mean-1.2.1 ]
RedundantVersion slot(2.6) keywords are overshadowed by versions: 2.6.6-r1, 2.6.6-r2
2.5.8-r1 : 2.5 ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~sparc
2.5.8 : 2.5 amd64 x86 ~alpha arm arm64 hppa ia64 ppc ppc64 sparc
PotentialStable slot(2.5), stabled arches: [ amd64, arm, arm64, hppa, ppc, ppc64, s390, sparc, x86 ], potential: [ ~alpha ]
PotentialStable slot(2.5), stabled arches: [ amd64, arm, arm64, hppa, ppc, ppc64, s390, sparc, x86 ], potential: [ ~alpha ]
2.4.10 : 2.4 amd64 x86 ~alpha arm arm64 hppa ia64 ppc ppc64 sparc
NonexistentBlocker nonexistent blocker DEPEND="!<dev-ruby/rdoc-3.9.4": no matches in repo history
NonexistentBlocker nonexistent blocker DEPEND="!<dev-ruby/rubygems-1.8.10-r1": no matches in repo history
NonexistentBlocker nonexistent blocker RDEPEND="!<dev-ruby/rdoc-3.9.4": no matches in repo history
NonexistentBlocker nonexistent blocker RDEPEND="!<dev-ruby/rubygems-1.8.10-r1": no matches in repo history
PotentialStable slot(2.4), stabled arches: [ amd64, arm, arm64, ppc, ppc64, s390, x86 ], potential: [ ~alpha ]
NonexistentBlocker nonexistent blocker DEPEND="!<dev-ruby/rdoc-3.9.4": no matches in repo history
NonexistentBlocker nonexistent blocker DEPEND="!<dev-ruby/rubygems-1.8.10-r1": no matches in repo history
NonexistentBlocker nonexistent blocker RDEPEND="!<dev-ruby/rdoc-3.9.4": no matches in repo history
NonexistentBlocker nonexistent blocker RDEPEND="!<dev-ruby/rubygems-1.8.10-r1": no matches in repo history
PotentialStable slot(2.4), stabled arches: [ amd64, arm, arm64, ppc, ppc64, s390, x86 ], potential: [ ~alpha ]

Masks

  • Ruby 2.4 is no longer supported by upstream and no longer gets security updates since the 2.4.10 release. Use ruby 2.5 or later instead.
    dev-lang/ruby:2.4
    Hans de Graaff <graaff@gentoo.org> (2020-06-14 00:00:00 +0000 UTC)

Package Metadata

Changelog