Pkgcheck Warnings

  • All Versions
  • 9999
  • 2.33
  • 2.32-r8
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_10
    • RedundantVersion
      slot(2.2) keywords are overshadowed by version: 2.33
  • 2.32-r7
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_10
  • 2.32-r6
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_10
    • RedundantVersion
      slot(2.2) keywords are overshadowed by version: 2.32-r7
  • 2.31-r7
    • PythonCompatUpdate
      PYTHON_COMPAT update available: python3_10
    • RedundantVersion
      slot(2.2) keywords are overshadowed by versions: 2.32-r6, 2.32-r7
    • VulnerablePackage
      vulnerable via glsa(202101-20) ( ( ('fullver',) ver-rev < 2.32-r5 ) && not ( ('fullver',) ver-rev >= 2.32-r5 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, riscv, s390, sparc, x86
  • 2.30-r9
    • PythonCompatUpdate
      PYTHON_COMPAT updates available: python3_9, python3_10
    • RedundantVersion
      slot(2.2) keywords are overshadowed by versions: 2.32-r6, 2.32-r7
    • VulnerablePackage
      vulnerable via glsa(202101-20) ( ( ('fullver',) ver-rev < 2.32-r5 ) && not ( ('fullver',) ver-rev >= 2.32-r5 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, riscv, s390, sparc, x86
  • 2.25-r11
    • DeprecatedEapi
      uses deprecated EAPI 5
    • DeprecatedEclass
      uses deprecated eclass: epatch (migrate to eapply from EAPI 7)
    • RedundantVersion
      slot(2.2) keywords are overshadowed by versions: 2.30-r9, 2.32-r6, 2.32-r7
    • VulnerablePackage
      vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
    • VulnerablePackage
      vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
    • VulnerablePackage
      vulnerable via glsa(202006-04) ( ( ('fullver',) ver-rev < 2.30-r8 ) && not ( ('fullver',) ver-rev >= 2.30-r8 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
    • VulnerablePackage
      vulnerable via glsa(202101-20) ( ( ('fullver',) ver-rev < 2.32-r5 ) && not ( ('fullver',) ver-rev >= 2.32-r5 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
  • 2.19-r2
    • RedundantVersion
      slot(2.2) keywords are overshadowed by versions: 2.25-r11, 2.30-r9, 2.31-r7, 2.32-r6, 2.32-r7, 2.32-r8, 2.33
    • VulnerablePackage
      vulnerable via glsa(201602-02) ( ( ('fullver',) ver-rev < 2.21-r2 ) && not ( ('fullver',) ver-rev >= 2.21-r2 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(201702-11) ( ( ('fullver',) ver-rev < 2.23-r3 ) && not ( ('fullver',) ver-rev >= 2.23-r3 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(201706-19) ( ( ('fullver',) ver-rev < 2.23-r4 ) && not ( ('fullver',) ver-rev >= 2.23-r4 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(201804-02) ( ( ('fullver',) ver-rev < 2.25-r11 ) && not ( ('fullver',) ver-rev >= 2.25-r11 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(202006-04) ( ( ('fullver',) ver-rev < 2.30-r8 ) && not ( ('fullver',) ver-rev >= 2.30-r8 ) ), keyword: amd64
    • VulnerablePackage
      vulnerable via glsa(202101-20) ( ( ('fullver',) ver-rev < 2.32-r5 ) && not ( ('fullver',) ver-rev >= 2.32-r5 ) ), keyword: amd64

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.