sys-libs/
glibc

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arch: [ riscv ], all versions are unstable: [ 2.30-r8, 2.31-r2, 2.31-r3 ]
UnstableOnly for arches: [ alpha, ia64 ], all versions are unstable: [ 2.25-r11, 2.30-r8, 2.31-r2, 2.31-r3 ]
UnstableOnly for arch: [ riscv ], all versions are unstable: [ 2.30-r8, 2.30-r9, 2.31-r4, 2.31-r5 ]
UnstableOnly for arches: [ alpha, ia64 ], all versions are unstable: [ 2.25-r11, 2.30-r8, 2.30-r9, 2.31-r4, 2.31-r5 ]
9999 : 2.2 T amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
OutdatedBlocker outdated blocker BDEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
2.31-r5 : 2.2 T ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc
OutdatedBlocker outdated blocker BDEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
2.31-r4 : 2.2 T ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc
OutdatedBlocker outdated blocker BDEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
RedundantVersion slot(2.2) keywords are overshadowed by version: 2.31-r5
2.30-r9 : 2.2 T ~amd64 ~x86 ~alpha ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 sparc
LaggingStable slot(2.2), stabled arch: [ sparc ], lagging: [ ~amd64, ~arm, ~arm64, ~hppa, ~ppc, ~ppc64, ~s390, ~x86 ]
OutdatedBlocker outdated blocker BDEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
PotentialStable slot(2.2), stabled arch: [ sparc ], potentials: [ ~alpha, ~ia64, ~riscv ]
2.30-r8 : 2.2 T amd64 x86 ~alpha arm arm64 hppa ~ia64 ppc ppc64 sparc
PotentialStable slot(2.2), stabled arches: [ amd64, arm, arm64, hppa, ppc, ppc64, s390, sparc, x86 ], potentials: [ ~alpha, ~ia64, ~riscv ]
OutdatedBlocker outdated blocker BDEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
2.25-r11 : 2.2 S amd64 x86 ~alpha arm arm64 hppa ~ia64 ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(2.2) keywords are overshadowed by version: 2.30-r8
VulnerablePackage vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
VulnerablePackage vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(2.2) keywords are overshadowed by version: 2.30-r8
VulnerablePackage vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
VulnerablePackage vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keywords: alpha, amd64, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc64, s390, sparc, x86
2.19-r2 : 2.2 S ~amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
RedundantVersion slot(2.2) keywords are overshadowed by versions: 2.25-r11, 2.30-r8, 2.31-r2, 2.31-r3
VulnerablePackage vulnerable via glsa(201602-02) ( ( ('fullver',) ver-rev < 2.21-r2 ) && not ( ('fullver',) ver-rev >= 2.21-r2 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201702-11) ( ( ('fullver',) ver-rev < 2.23-r3 ) && not ( ('fullver',) ver-rev >= 2.23-r3 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201706-19) ( ( ('fullver',) ver-rev < 2.23-r4 ) && not ( ('fullver',) ver-rev >= 2.23-r4 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201804-02) ( ( ('fullver',) ver-rev < 2.25-r11 ) && not ( ('fullver',) ver-rev >= 2.25-r11 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keyword: amd64
OutdatedBlocker outdated blocker DEPEND="!<sys-devel/bison-2.7": last match removed 2.03 years ago
RedundantVersion slot(2.2) keywords are overshadowed by versions: 2.25-r11, 2.30-r8, 2.30-r9, 2.31-r4, 2.31-r5
VulnerablePackage vulnerable via glsa(201602-02) ( ( ('fullver',) ver-rev < 2.21-r2 ) && not ( ('fullver',) ver-rev >= 2.21-r2 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201702-11) ( ( ('fullver',) ver-rev < 2.23-r3 ) && not ( ('fullver',) ver-rev >= 2.23-r3 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201706-19) ( ( ('fullver',) ver-rev < 2.23-r4 ) && not ( ('fullver',) ver-rev >= 2.23-r4 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201804-02) ( ( ('fullver',) ver-rev < 2.25-r11 ) && not ( ('fullver',) ver-rev >= 2.25-r11 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201903-09) ( ( ('fullver',) ver < 2.26.0 ) && not ( ('fullver',) ver >= 2.26.0 ) ), keyword: amd64
VulnerablePackage vulnerable via glsa(201908-06) ( ( ('fullver',) ver-rev < 2.28-r4 ) && not ( ('fullver',) ver-rev >= 2.28-r4 ) ), keyword: amd64

Masks

  • Matthias Maier <tamiko@gentoo.org> (2017-05-21 and later updates) These old versions of toolchain packages (binutils, gcc, glibc) are no longer officially supported and are not suitable for general use. Using these packages can result in build failures (and possible breakage) for many packages, and may leave your system vulnerable to known security exploits. If you still use one of these old toolchain packages, please upgrade (and switch the compiler / the binutils) ASAP. If you need them for a specific (isolated) use case, feel free to unmask them on your system.
    <sys-libs/glibc-2.30-r8
    Michał Górny <mgorny@gentoo.org> (0001-01-01 00:00:00 +0000 UTC)

Package Metadata

Changelog