dev-db/
mysql

A fast, multi-threaded, multi-user SQL database server

https://www.mysql.com/

Version 8.0.20 is available upstream. Please consider updating!
It seems that version 8.0.20 is available upstream, while the latest version in the Gentoo tree is 5.6.45.

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arches: [ hppa, ia64, sparc ], all versions are unstable: [ 5.6.45-r2, 5.7.27-r1, 5.7.29, 5.7.30, 8.0.19-r1, 8.0.20 ]
UnstableOnly for arches: [ hppa, ia64, sparc ], all versions are unstable: [ 5.6.45-r2, 5.7.27-r1, 5.7.29, 5.7.30, 8.0.19-r1, 8.0.20 ]
8.0.20 : 0 T amd64 x86 alpha arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc
LaggingStable slot(0), stabled arches: [ amd64, arm, arm64, x86 ], lagging: [ ~ppc, ~ppc64 ]
PotentialStable slot(0), stabled arches: [ amd64, arm, arm64, x86 ], potentials: [ ~hppa, ~ia64, ~sparc ]
LaggingStable slot(0), stabled arches: [ amd64, arm, arm64, x86 ], lagging: [ ~ppc, ~ppc64 ]
PotentialStable slot(0), stabled arches: [ amd64, arm, arm64, x86 ], potentials: [ ~hppa, ~ia64, ~sparc ]
8.0.19-r1 : 0 T amd64 x86 alpha arm ~arm64 ~hppa ~ia64 ~ppc ppc64 ~sparc
5.7.30 : 0 T amd64 x86 alpha arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 8.0.20
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 8.0.20
5.7.29 : 0 T amd64 x86 alpha arm ~arm64 ~hppa ~ia64 ~ppc ppc64 ~sparc
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 8.0.19-r1
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 8.0.19-r1
5.7.27-r1 : 0 T amd64 x86 alpha arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
5.6.45-r2 : 0 T amd64 x86 alpha arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 5.7.27-r1
MissingUseDepDefault RDEPEND="!dev-db/mariadb-connector-c[mysqlcompat]": USE flag 'mysqlcompat' missing from packages: [ dev-db/mariadb-connector-c-3.1.6, dev-db/mariadb-connector-c-3.1.7, dev-db/mariadb-connector-c-3.1.8, dev-db/mariadb-connector-c-9999 ]
RedundantVersion slot(0) keywords are overshadowed by version: 5.7.27-r1

Masks

  • Requires <OpenSSL-1.1.x. Please migrate to >=dev-db/mysql-5.7. Masked for removal in 30 days.
    <dev-db/mysql-5.7
    Thomas Deutschmann <whissi@gentoo.org> (2020-04-30 00:00:00 +0000 UTC)

Package Metadata

Changelog