dev-libs/
libsecp256k1

Optimized C library for EC operations on curve secp256k1

https://github.com/bitcoin-core/secp256k1

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arch: [ ppc64 ], all versions are unstable: [ 0.1_pre20170928, 0.1_pre20190401 ]
UnstableOnly for arches: [ arm64, ppc ], all versions are unstable: [ 0.0.0_pre20151118, 0.0.0_pre20161213, 0.1_pre20170928, 0.1_pre20190401 ]
UnstableOnly for arch: [ ppc64 ], all versions are unstable: [ 0.1_pre20170928, 0.1_pre20190401 ]
UnstableOnly for arches: [ arm64, ppc ], all versions are unstable: [ 0.0.0_pre20151118, 0.0.0_pre20161213, 0.1_pre20170928, 0.1_pre20190401 ]
0.1_pre20190401 : 0 T ~amd64 ~x86 alpha ~arm ~arm64 hppa ia64 ~ppc ~ppc64 sparc
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
0.1_pre20170928 : 0 T ~amd64 ~x86 alpha ~arm ~arm64 hppa ia64 ~ppc ~ppc64 sparc
RedundantVersion slot(0) keywords are overshadowed by version: 0.1_pre20190401
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
RedundantVersion slot(0) keywords are overshadowed by version: 0.1_pre20190401
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
0.0.0_pre20161213 : 0 T ~amd64 ~x86 alpha ~arm ~arm64 hppa ia64 ~ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
DeprecatedEclass uses deprecated eclass: [ ltprune (no replacement) ]
RedundantVersion slot(0) keywords are overshadowed by versions: 0.1_pre20170928, 0.1_pre20190401
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
DeprecatedEapi uses deprecated EAPI 5
DeprecatedEclass uses deprecated eclass: [ ltprune (no replacement) ]
RedundantVersion slot(0) keywords are overshadowed by versions: 0.1_pre20170928, 0.1_pre20190401
RequiredUseDefaults profile: 'default/linux/arm/17.0' (32 total) failed REQUIRED_USE: experimental
0.0.0_pre20151118 : 0 T amd64 x86 alpha arm ~arm64 hppa ia64 ~ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
DeprecatedEclass uses deprecated eclass: [ ltprune (no replacement) ]
PotentialStable slot(0), stabled arches: [ amd64, arm, x86 ], potentials: [ ~arm64, ~ppc ]
DeprecatedEapi uses deprecated EAPI 5
DeprecatedEclass uses deprecated eclass: [ ltprune (no replacement) ]
PotentialStable slot(0), stabled arches: [ amd64, arm, x86 ], potentials: [ ~arm64, ~ppc ]

Package Metadata

Changelog