dev-util/
coccinelle

Program matching and transformation engine

http://coccinelle.lip6.fr/

Available Versions

Version amd64 x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
Warnings For All Versions
UnstableOnly for arches: [ amd64, x86 ], all versions are unstable: [ 1.0.5, 1.0.6, 1.0.8 ]
UnstableOnly for arches: [ amd64, x86 ], all versions are unstable: [ 1.0.5, 1.0.6, 1.0.8 ]
1.0.8 : 0 S, T ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
1.0.6 : 0 S, T ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
RedundantVersion slot(0) keywords are overshadowed by version: 1.0.8
RedundantVersion slot(0) keywords are overshadowed by version: 1.0.8
1.0.5 : 0 S, T ~amd64 ~x86 alpha arm arm64 hppa ia64 ppc ppc64 sparc
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 1.0.6, 1.0.8
DeprecatedEapi uses deprecated EAPI 5
RedundantVersion slot(0) keywords are overshadowed by versions: 1.0.6, 1.0.8

Masks

  • This package is masked and could be removed soon!
    The mask comment indicates that this package is scheduled for removal from our package repository.
    Please review the mask information below for more details.

    dev-util/coccigrep is py2-only and requires coccinelle with Python bindings. dev-util/coccinelle has py2 bindings and fails to build with python disabled (bug #701904). Both packages are unmaintained. Removal in 30 days. Bug #734630.
    dev-util/coccinelle
    Michał Górny <mgorny@gentoo.org> (2020-08-03 00:00:00 +0000 UTC)
This package needs a new maintainer!
If you are interested in helping with the maintenance of coccinelle, please get in touch with our Proxy Maintainers team.

Package Metadata

Changelog